Austrian Linux Forum

2.6.9 make mrproper Fehler

Kategorien: Linux Software
15 Antworten
Pechosko
Pechosko am Montag, 1. November 2004 um 07:50
Hallo Bin gerade beim Kernelbacken. Habe mich an [url=http://www.digitalhermit.com/linux/Kernel-Build-HOWTO.html/]diese[/url] Anleitung gehalten, leider funktioniert aber make mrproper nicht. Meldung: grep: /usr/include/bits/stat.h: Datei oder Verzeichnis nicht gefunden . Ich habe manuell nachgeschaut und das Verzeichnis gibts wirklich nicht. :) Ich habe den Debian Sarge Insaller auf meinen Sis 630 Laptop. Ohne make mrproper möchte ich das Ganze doch lieber nicht laufen lassen, aber dass es einfach das Verzeichnis nicht gibt? Wäre schön, wenn jemand eine Lösung wüsste. mfg Pechosko [Edit]: Nachtrag: Die grundlegenden Funktionen für Netzwerk und 10/100 mbit habe ich natürlich aktiviert. Als ich den Kernel das erste mal machte, konnte ich mich auch erinnern dass ein Modul namens Sis900(meine Netzwerkkarte) gemacht wurde, beim zweiten Mal habe ich nicht zugeschaut.

Kommentare

Dookie
Dookie am Freitag, 29. Oktober 2004 um 15:59

Hi Pechosko,

apt-get install libc6-dev

Dann haste die Datei.
Ich hoffe bei deinem "hier" das ich leider nicht im Browser öffnen kann ist auch ein Hinweis auf die anderen Pakete die du zum Kernelbacken brauchst.


Gruß

Dookie

haltbar
haltbar am Freitag, 29. Oktober 2004 um 16:18

der link geht eh (einfach / am ende entfernen)
[list] The minimum software versions for a kernel build are found in the ./Documentation/Changes file of the installed sources. They are as follows: 2.4.x series

o Gnu C 2.91.66 # gcc --version
o Gnu make 3.77 # make --version
o binutils 2.9.1.0.25 # ld -v
o util-linux 2.10o # fdformat --version
o modutils 2.4.2 # insmod -V
o e2fsprogs 1.19 # tune2fs
o reiserfsprogs 3.x.0b # reiserfsck 2>&1|grep reiserfsprogs
o pcmcia-cs 3.1.21 # cardmgr -V
o PPP 2.4.0 # pppd --version
o isdn4k-utils 3.1pre1 # isdnctrl 2>&1|grep version



2.6.x series

o Gnu C 2.95.3 # gcc --version
o Gnu make 3.78 # make --version
o binutils 2.12 # ld -v
o util-linux 2.10o # fdformat --version
o module-init-tools 0.9.10 # depmod -V
o e2fsprogs 1.29 # tune2fs
o jfsutils 1.1.3 # fsck.jfs -V
o reiserfsprogs 3.6.3 # reiserfsck -V 2>&1|grep reiserfsprogs
o xfsprogs 2.1.0 # xfs_db -V
o pcmcia-cs 3.1.21 # cardmgr -V
o quota-tools 3.09 # quota -V
o PPP 2.4.0 # pppd --version
o isdn4k-utils 3.1pre1 # isdnctrl 2>&1|grep version
o nfs-utils 1.0.5 # showmount --version
o procps 3.1.13 # ps --version
o oprofile 0.5.3 # oprofiled --version
[/list]

Dookie
Dookie am Freitag, 29. Oktober 2004 um 17:06

für [b]make menuconfig[/b] wirst du noch ncurses brauchen
für [b]make xconfig[/b] oder [b]make gconfig[/b] noch qt bzw. gtk.
Zum suchen von Dateien in Packeten empfehle ich
www.debian.org/distrib/packages


Gruß

Dookie

theEdge
theEdge am Freitag, 29. Oktober 2004 um 17:37

Halt dich einfach an [url=tinyurl.com/3ts95]diese[/url] Anleitung ^^

In deinem Falle (debian) ist auch der Link von greggae äußerst interessant

Pechosko
Pechosko am Freitag, 29. Oktober 2004 um 22:26

@all: Danke für die Hilfe, der Tipp von Dookie wirkte sofort.
@theEdge: Ich hab dein Howto auch einbezogen, nur das Andere ist noch ausführlicher. Danke für das gute Tutorial


Also, jetzt ist eigentlich alles butterweich gegangen. Das Grubeditieren auch. Ich hab mich wirklich an Alles gehalten. Aber nach dem Reboot der große Schock:
Ich boote den neuen Kernel und nach kurzer Zeit(bis zu den Zeilen alles gut)
Interessante Zeilen:
RAMDISK:cramfs filesystem found at block 0
RAMDISK: Loading 4316KiB [1 disk] into ram disk....done
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
:evil:

Hoffe, jemand kennt sich aus.

greggae
greggae am Samstag, 30. Oktober 2004 um 13:14

das deutet darauf hin, dass die kernel-parameter (append-line) kein root=/dev/partition
enthalten - du musst dem kernel sagen wo sein root-fs liegt, sonst zuckt er aus :)

Pechosko
Pechosko am Samstag, 30. Oktober 2004 um 16:51

Danke, greggae, aber der Fehler lag bisschen wo anders.

Danke an Stephanw aus linuxforen.de, ich musste bei der Suche(auf linuxforen.de) einfach ein Stichwort aus der betreffenden Zeile eingeben und kam schon zu seiner Lösung. [url=www.linuxforen.de/forums/showthread.php?t=157541&highlight=vfs/]Thread auf Linuxforen.de[/url]

Jetzt funktioniert das Netzwerk aber nicht, ich kann nicht pingen und beim Starten kommt eine Fehlermeldung(die unten bei ifup genauso kommt):

root#:/sbin/ifup eth0 inet dhcp
eth0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
exiting.
Failed to bring up eth0


Ich hoffe sehr, dass ich nichts vergessen habe und den Kernel noch einmal machen muss.

sec
sec am Samstag, 30. Oktober 2004 um 16:55

Sieht so aus, als ob du den Treiber für deine Netzwerkkarte vergessen hättest. Falls du ihn als Modul kompiliert hast, musst du das Modul erst laden.

Pechosko
Pechosko am Samstag, 30. Oktober 2004 um 21:30

Das Modul gibt es anscheinend wirklich nicht. Wo finde ich die .config Datei, die ich gespeichert habe, bevor ich ans wirkliche kompilieren gegangen bin?

mfg

sec
sec am Samstag, 30. Oktober 2004 um 22:28

Dort, wo dein Kernel liegt. Also unter /usr/src/linux/ falls du den entsprechenden Symlink gesetzt hast. Du musst nur wieder in das Verzeichnis, in dem du den Kernel geconft hast, und noch mal make menuconfig oder so aufrufen, und den Treiber für deine Karte anhakeln.

greggae
greggae am Sonntag, 31. Oktober 2004 um 12:06

seit einiger zeit gibt es im kernel auch die option, das config-file im laufenden betrieb per /proc/config.gz auszulesen - ich als notorischer config-file-verschlamper aktiviere das, seit ich die option kenne, immer.

Pechosko
Pechosko am Sonntag, 31. Oktober 2004 um 18:36

Victoria!

Ich habs letztendlich geschafft.
@sec: Du hattest Recht, die .config bleibt ja bestehen, nur hab ich vor dem 3. Kernelmakedurchlauf noch mal makemrproper gemacht, konnte also die gesamte Menuconfigprozedur noch einmal machen.
@all: Danke für die Tipps. Jetzt kommt x.org dran, das ja leider noch nicht als debian binary gibt.

theEdge
theEdge am Sonntag, 31. Oktober 2004 um 18:39

hey, x.org!

wär ein hammer wenn du dafür ein tutorial schreiben würdest, ich hab nämlich vor evtl. auf eine aktuelle verisom umzusteigen. die dann "echte" transparenz kann. nicht immer nur den desktophintergrund durchscheinen lassen...

sec
sec am Sonntag, 31. Oktober 2004 um 20:39

[quote]hey, x.org!

wär ein hammer wenn du dafür ein tutorial schreiben würdest, ich hab nämlich vor evtl. auf eine aktuelle verisom umzusteigen. die dann "echte" transparenz kann. nicht immer nur den desktophintergrund durchscheinen lassen...[/quote]
Nur als Warnung, anscheinend ist dieses Transparenz-Feature mit ATI-Karten eher ein Krampf, da die Render-Extension da nicht hardwarebeschleunigt wird. Danke, ATI.

theEdge
theEdge am Montag, 1. November 2004 um 07:50

*hehe*

deswegen hab ich auf die Tips in diesem Forum gehört und mir eine Nvidia gekauft :)