Austrian Linux Forum

vfat mounten

Kategorien: Hard & Software
14 Antworten
Markus René Einicher
Markus René Einicher am Sonntag, 3. Juli 2005 um 13:29
Weiß jemand von euh wie amn vfat in rw mountet? er zeigt mir im mount Befehl an das es rw is aber wenn ich eine Daei raufziehen will sagt er das die platte schreibgeschützt ist, is aber kein ro und die chmod ist 777. Hab da schon alle Varianten durchprobiert und die ganzevorige Woche gings auch, da hat aMule dann drauf zugreifn können, aber jetzt auf einmal tut er sie wieder anders mounten.

Kommentare

gravedigga
gravedigga am Mittwoch, 22. Juni 2005 um 06:56

hast du "user" oder "users" gesetzt?
setz user oder users, dann kannst du als ganz normaler user auch mounten. dann dürfte das mit dem lesezugriff auch klappen.

Markus René Einicher
Markus René Einicher am Mittwoch, 22. Juni 2005 um 08:58

was ist eigentlich der unterschied zwischen mtab und fstab?

ja hab mi user probiert und mit users und umask hab ich auch schon alle varianten durch, hab sogar von der externen festplatte die ganze zeile rauf kopiert, immer nur readonly obwohl das nirgends steht.

theEdge
theEdge am Mittwoch, 22. Juni 2005 um 09:47

[code]root@bernhard:/home/Kastna# cat /etc/fstab | grep shared
/dev/hdb7 /shared vfat noauto,users,exec 0 0
[/code]

shared is FAT32, als austauschplatte zwischen VMWare und Linux

gravedigga
gravedigga am Mittwoch, 22. Juni 2005 um 11:53

in der fstab stehen alle mounts drinnen

und in der mtab die aktuell gemounteten

Markus René Einicher
Markus René Einicher am Sonntag, 26. Juni 2005 um 07:39

Darf ich in mtab dann überhaupt etwas ändern? Klüger is es das in fstab zu ändern und dan neu einuzhängen oder?

Also das Betriebssystem mountet alles so:

/dev/hda5 /mnt/speicher vfat umask=0000,user,iocharset=utf-8 0 0

Obwohl umask 0000 ist werden die chmod nur auf 775 gesetzt. Ich will da aber 777 haben.

ich selbst kann mit dem mount /mnt/speicher gar nichts mehr machen, da kommt diese Meldung:
[quote]mount: Falscher Dateisystemtyp, ungültige Optionen, der
»Superblock« von /dev/hda5 ist beschädigt oder es sind
zu viele Dateisysteme eingehängt[/quote]W

Wenn ich aber ins Kontrollzetrum zu den Partionen geh und da die Part einhäng geht das ohne Probleme. Brauch das unbedingt so weil das auf meiner 200GB Platte der Mittelteil is und ich hinten und vorne des öfteren die Betriebssystem wechsle, weswegen ich die DAetn immer auf die mittlere rauftu und dami sowohl WIn als auch Linux Daten lesen und schreiben können mus es fat sein.

am Sonntag, 26. Juni 2005 um 14:51

bei fat gibts doch nicht mal chmod definitionen oder chown oder ? O_o

Markus René Einicher
Markus René Einicher am Sonntag, 26. Juni 2005 um 15:25

Das ist doch egal, wenn er die mountet teilt er ihnen eine chmod zu.

am Sonntag, 26. Juni 2005 um 18:18

fat ist einfach kein dateisystem, sondern ne krankheit :P

Markus René Einicher
Markus René Einicher am Sonntag, 26. Juni 2005 um 18:21

Da kann doch das fat nichts dafür wenns fehlerhaft eingehängt wird, vorher isses ja auch gegangen.

am Sonntag, 26. Juni 2005 um 21:17

aber es kann was für die schlechte zugriffskontrolle, für die unredundant gesicherte filetabelle usw...

Markus René Einicher
Markus René Einicher am Freitag, 1. Juli 2005 um 06:37

Wenn ich das so mounte:
[code]/dev/hda5 /mnt/speicher vfat umask=0000 0 0[/code]

dann gibt er allem auf der platte chmod 0777 aber wenn ich schreiben will sagt er "Platte schreibgeschützt". Die ro Option steht da aber nirgends! FUT!

am Freitag, 1. Juli 2005 um 16:38

dann "rw" mit angeben :)

Markus René Einicher
Markus René Einicher am Sonntag, 3. Juli 2005 um 09:05

bringt ncihts.

am Sonntag, 3. Juli 2005 um 13:29

dann bin ich ebenso ratlos :(